Impacted performance on Merchant Dashboard
Incident Report for Skio
Resolved
The behavior causing degraded performance in Skio has been resolved. All systems are operating as expected now.
Posted Dec 12, 2023 - 17:25 EST
Identified
Our team has identified the cause of the degradation and is applying a fix.
Posted Dec 12, 2023 - 15:48 EST
Investigating
Our team is investigating an incident causing degraded performance and slow load times on our merchant facing dashboard.
Posted Dec 12, 2023 - 15:27 EST
This incident affected: Skio Merchant Portal.