Customers are unable to view the customer portal
Incident Report for Skio
Resolved
This issue has been resolved and access to the customer portal has been fully restored.
Posted Aug 09, 2023 - 17:33 EDT
Identified
We've identified an issue that prevents the customer portal from loading correctly. We're actively working to resolve this with urgent priority.
Posted Aug 09, 2023 - 17:19 EDT
This incident affected: Skio Customer Portal.