Skio merchant dashboard is experiencing difficulties.
Incident Report for Skio
Resolved
Our team has resolved this incident and all platforms are fully functional again.
Posted Nov 06, 2023 - 13:31 EST
Update
We are continuing to investigate this issue that is degrading the customer portal and the merchant dashboard.
Posted Nov 06, 2023 - 12:56 EST
Update
We are continuing to investigate this issue.
Posted Nov 06, 2023 - 12:55 EST
Investigating
Our team is investigating an issue that is affecting the Skio Merchant Dashboard. We'll post further updates here as we continue to work on this incident.
Posted Nov 06, 2023 - 12:29 EST
This incident affected: Skio Customer Portal and Skio Merchant Portal.