Customer Portal Login unavailable for some customers

Incident Report for Skio

Resolved

We have resolved the Customer Portal Login issue.
Posted May 29, 2025 - 10:12 EDT

Update

We have resolved the Customer Portal Login issue.
Posted May 29, 2025 - 10:11 EDT

Investigating

We are currently investigating an issue where customers are unable to access the Customer Portal. Thank you for your patience while we look into this.
Posted May 29, 2025 - 10:09 EDT
This incident affected: Skio Customer Portal.