Skio Dashboard Login issue

Incident Report for Skio

Resolved

This incident has been resolved.
Posted May 29, 2025 - 09:24 EDT

Update

We have identified and resolved the dashboard login issue.
Posted May 29, 2025 - 09:23 EDT

Investigating

We are currently experiencing an issue where logging into the Skio Dashboard is slow. We're investigating the issue and will update once we have more information.
Posted May 29, 2025 - 09:01 EDT
This incident affected: Skio Merchant Portal.