Editing subscriptions from merchant dashboard is broken
Incident Report for Skio
Resolved
Subscriptions in the Merchant Portal are now fully functional again.
Posted Sep 21, 2023 - 19:12 EDT
Identified
We’re working on a fix to editing subscription from the merchant dashboard.
Posted Sep 21, 2023 - 19:00 EDT
This incident affected: Skio Merchant Portal.