Merchant dashboard experiencing slowness.
Incident Report for Skio
Resolved
This issue is resolved and the merchant dashboard is functioning at top performance!
Posted Nov 01, 2023 - 13:30 EDT
Monitoring
We've identified the root cause for the degraded performance on the merchant dashboard. We'll continue monitoring this resolution.
Posted Nov 01, 2023 - 12:02 EDT
Investigating
We are currently investigating a performance degradation on the merchant facing dashboard.
Posted Nov 01, 2023 - 11:30 EDT
This incident affected: Skio Merchant Portal.